23 Replies Latest reply: Apr 2, 2011 9:47 PM by Kepi RSS

New GTX 460 lag when engaging enemy

afflictedmed
Sorry for post*  Search function was not working.

I just upgraded my 4850 to a GTX 460.  Now I am experiencing lag everytime I engage the enemy or they engage me. Messed with the settings and nothing makes a difference.  Never had these problem with my old 4850.  Anyone know the source of this lag/ hitching?

I have a 24MB D/L and 4 MB U/L, so my connection isn't the problem.  Everything worked until I switch cards.


thanks in advance.
  • Re: New GTX 460 lag when engaging enemy
    G915
    The source of this problem is your GTX460. To be more exact - Treyarch's absolute inability to optimise this game for one of today's most popular GFX cards. You can't fix this problem yourself, sorry.
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed
    Isn't that great news. thanks for the reply.  looks like I need a new FPS to obsess over.
  • Re: New GTX 460 lag when engaging enemy
    Gruul Damage

    G915 wrote:

     

    The source of this problem is your GTX460. To be more exact - Treyarch's absolute inability to optimise this game for one of today's most popular GFX cards. You can't fix this problem yourself, sorry.



    Yes you can:

    http://www.geforce.com/#/Optimize/Guides/blackops-tweak-guide

    I run a GTX460 and it works very well.  The only issue is turning on Shader Warming as the guide suggests will cause the game to kick you on the larger maps and not having it turned on can cause stuttering for the first few seconds of any game.  But after 20 seconds or so, the games works great with 60fps consistently.  I just won't engage the enemy until 20 seconds have passed so I don't really notice that issue.  And I run it on Windows 7.  Windows XP is even better.
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed
    Sorry, should have been more specific.  My problems are in multiplayer.  Single player is fine.
  • Re: New GTX 460 lag when engaging enemy
    Gruul Damage

    AfflictedMed wrote:

     

    Sorry, should have been more specific.  My problems are in multiplayer.  Single player is fine.



    I have no trouble in multiplayer (except the initial problem due to shader warming) using the tweaks from the link I posted.  I had troubles initially when I first got the GTX, but few since I implemented the tweaks.
  • Re: New GTX 460 lag when engaging enemy
    whitetigerswt
    i had a somewhat similar problem, try the game with shadows off.
  • Re: New GTX 460 lag when engaging enemy
    G915

    Gruul Damage wrote:

     

    Yes you can:
    http://www.geforce.com/#/Optimize/Guides/blackops-tweak-guide
    I run a GTX460 and it works very well.  The only issue is turning on Shader Warming as the guide suggests will cause the game to kick you on the larger maps and not having it turned on can cause stuttering for the first few seconds of any game.  But after 20 seconds or so, the games works great with 60fps consistently.  I just won't engage the enemy until 20 seconds have passed so I don't really notice that issue.  And I run it on Windows 7.  Windows XP is even better.



    FPS isn't the problem, you can easily get 250FPS with gtx460 (and a proper cfg). The problem is that the game stutters and lags every time someone shoots at you (or you shoot at someone) in MP.
  • Re: New GTX 460 lag when engaging enemy
    Malebolgiasatan

    G915 wrote:

     

    FPS isn't the problem, you can easily get 250FPS with gtx460 (and a proper cfg). The problem is that the game stutters and lags every time someone shoots at you (or you shoot at someone) in MP.



    I have the exact same problem, but ONLY on multiplayer..   Solo/Zombie works without a glitch..

    Using  a Gigabyte 460 GTX

    Edit:   Just tried something of GeForce.com that i havent tried before.
    "seta cg_brass "1" - If set to 0, disables all ejecting brass, such as expended shells from your gun. This can improve FPS when firing your weapon."

    Seems that it solved my trouble
  • Re: New GTX 460 lag when engaging enemy
    G915

    pcdev wrote:

     

    This issue should be fixed in the new Nvidia driver which should be due for release very soon.
    -pcdev-



    You just made me happy. Please keep us updated on the driver version (2??.??), drivers are easy to miss..
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed

    pcdev wrote:

     

    This issue should be fixed in the new Nvidia driver which should be due for release very soon.
    -pcdev-





    Yes!!  Im not going insane!  

    thanks for the reply pcdev!
  • Re: New GTX 460 lag when engaging enemy
    XDark_HonorX
    You shoulda just stayed with ATI......  but im glad nvidia is getting off there ass to fix there driver problem for you.
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed
    Maybe.  Its funny, I went to nVidia because of their "stable" drivers!
  • Re: New GTX 460 lag when engaging enemy

    pcdev wrote:

     

    This issue should be fixed in the new Nvidia driver which should be due for release very soon.
    -pcdev-



    This is great news! Thanks so much for the update pcdev
  • Re: New GTX 460 lag when engaging enemy
    kelaroost
    Your problem isnt your graphics card its your network provider,
    the hardware of your provider is causing the lag problems not your machine.
    I was fine on 20 meg but after i upgraded to 50 meg the exact same problem happened to me
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed

    kelaroost wrote:

     

    Your problem isnt your graphics card its your network provider,
    the hardware of your provider is causing the lag problems not your machine.
    I was fine on 20 meg but after i upgraded to 50 meg the exact same problem happened to me




    Worked fine for months.  Then went bad as soon as I switched cards.
  • Re: New GTX 460 lag when engaging enemy
    seagate40
    its the game trust me, It's a horribly coded game not optimized for PC...
    i got my com_maxfps 250, but i get 90-180fps but its not constint at all its jumps all over the place, up n down, i go in a building and i get 250 fps sometimes, but the fps should stay at 250fps lol and not move. like cod4 does maxed..and i think it looks better rofl.. black ops i play it at 1920x1200 res, everything else is off, textures are on normal... ive tried over 10 diffrent config's and no change, even tried changing the res and nothing..my buddy has same problem, i get more fps on bfbc2 maxed rofl dx11.... dont make sence, and for everyone that says they get 250 constint or 400-500fps constint, gtfo kids

    here are my pc specs

    CPU: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz (8 CPUs), ~4.2GHz
    Memory: Corsair Dominator GT 2000mhz-6GB- 3x2GB- DDR3 tripple channel
    Hard Drive: 2x Intel X25-M 160GB SSD Raid 0 + 2x WD Black 640GB
    Video Card: NVIDIA GeForce GTX 470 Tri SLI
    Monitor: Asus 25.5' Full HD 1920x1200
    Sound Card: Creative soundblaster X-FI Champianship Edition
    Operating System: Windows 7 64bit
    Motherboard: EVGA E760 CLASSIFIED 3 WAY SLI + Physics
  • Re: New GTX 460 lag when engaging enemy
    DarKCOD
    It's the Win7 FPS issue > http://community.callofduty.com/message/104965824#104965824
    But no one is acknowledging that it's a real problem, so it will never be fixed. Makes me angry since I get unplayable FPS and can't play what I spent $80 on, but on XP I get 100fps (But I'm not switching to XP for one application..).
  • Re: New GTX 460 lag when engaging enemy
    seagate40
    the new 270 driver did nothing for me..... mine does not stutter, it has fps lag, like everyone else
  • Re: New GTX 460 lag when engaging enemy
    Statewars Hockey
    My computer just hates this game. Rarely get over 40 FPS, yet I can go hop on Crysis 2 and get 60 and 220 on WaW.

    The whole game is just terribly optimized.
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed
    The new Beta drivers did not fix anything.  Hopefully its the next set.
  • Re: New GTX 460 lag when engaging enemy
    acash
    you went from ATI to nvidia did u do a driver sweeper make sure all ATI drivers were uninstalled? cause i owned a gtx460 and it rocked out pretty good on all high settings. do u have good enough ram and cpu?
  • Re: New GTX 460 lag when engaging enemy
    afflictedmed

    acash wrote:

     

    you went from ATI to nvidia did u do a driver sweeper make sure all ATI drivers were uninstalled? cause i owned a gtx460 and it rocked out pretty good on all high settings. do u have good enough ram and cpu?




    I did run driver sweeper before upgrading.  I have a AMD 550 dual core black series and 4 gigs of DDR2.  Admittedly, its not the greatest, but they were running BO fine before the card switch.

    Thanks for the reply.  And using driver sweeper is a great tip for anyone reading this thread.
  • Re: New GTX 460 lag when engaging enemy
    Kepi
    It's that frkn 1.07 patch... I was fine from day one, until this crappy patch. Had 150+ fps steady, with maxfps set to 333 which it hit regularly, but now I get serious fps drops with the slightest movement - let alone engaging an enemy.. That's with an oc'd 2600K & HD 6990.. Tried Catalyst 11.1 trough 11.4.. & no difference.. It's plain horrid.. FIX THIS PLS!!