14 Replies Latest reply: Jan 30, 2010 7:44 PM by PalZer0 RSS

Please Help...Game Lobby Closed Error.

ohlin5
Ok, so I love the MW2 game...when I can play it.

The problem is that there are times that the connection is good and everything works great, and then there are times when I simply CANNOT get in a game.  I will join up, it will hang for a while, and then finally after about 10-15 seconds it will boot me out and say "Game Lobby Closed".  There are times I do this 8-10 times in a row and then give up out of frustration.

Now, I have done a lot of Google searching about this issue (as I always do before I resort to posting on forums!), and I know I'm not the only one having this issue, but no one seems to have a fix for it.

I have tried many different ways of changing how I'm connected to XBL and none make any difference.  Also, just so everyone knows, my internet connection speed is not blazing, but it's not slow either (works well when I can get into a game)...my NAT is also set to "Open", so that shouldn't be a problem.

I have tried wiring my Xbox directly into my modem/router (provided through my ISP, I've talked to them and they have NO ports blocked), I have tried wiring my Xbox directly into my wireless router (with a reserved IP address and the Xbox set as the DMZ host), and no matter what I do it never solves the problem.

I have really run out of ideas as to how to fix this, and since I have tried so many different things I feel that this is a problem on IW's end (I could be wrong, but that's what it looks like.)

If anyone has ANY ideas or any information about this problem (i.e. when it will be fixed, if there is already a fix,etc.) please let me know!

Sorry for the large essay but I wanted to be thorough.

Thanks!

-ohlin5
  • Re: Please Help...Game Lobby Closed Error.
    p8ntball_junky
    Not your fault its the matchmaking system.
  • Re: Please Help...Game Lobby Closed Error.
    ACiDiCACiDiCA
    could be anything... so, without the luxury of testing each item on your network, plug a laptop directly into the network cable (to test the cable too) you're using for the xbox.

    test your speed and your ping on speedtest.net

    this will at least give you some info to work with and if you post it here others will surely be able to help you interpret the results

    ps. it sounds more serious than the otherwise crappy (for international players) matchmaking
  • Re: Please Help...Game Lobby Closed Error.
    ohlin5
    Ok I don't think that's the issue and like I said I don't have a real fast internet connection (stuck in a town with 1 ISP, so they charge rediculous rates!)

    Download: 1.02 Mbps

    Upload: .21 Mbps

    Ping: 135 ms

    As I said, nothing great at all, but as I did some more thinking I know this is not the issue because I have a friend 3 doors down the street who has an even slower connection than me, and he never has this problem. Any other ideas?
  • Re: Please Help...Game Lobby Closed Error.
    Phr057
    You are probably on a Moderate or Strict NAT.

    You'll notice that when searching for games solo, you find usually 1-4 games out of 50 or that it immediately puts you in a lobby and says: "Waiting for 7 more players".

    Depending on your network setup, your NAT could say OPEN, but it really may be moderate or strict. You would see this if you are going through more than one router or have a hub switch.

    Your real clue is from your search results. The game lobby closing is most likely because you got lucky and connected to a host with an open NAT, and then it was dropped.
  • Re: Please Help...Game Lobby Closed Error.
    Phr057
    Try this:

    On your Xbox
    Primary DNS: 4.2.2.2
    Secondary DNS: 192.168.1.1 (or whatever your router is)

    On your router
    Reserve a static DNS as 4.2.2.2

    I did this for my friend because he was on strict and now he is at a true open and find 50/50 games when searching.

    Disable the DMZ and all of the port forwarding first before trying this. Keep your IP settings to Automatic. DNS should be the only thing Manual.
  • Re: Please Help...Game Lobby Closed Error.
    ACiDiCACiDiCA
    hmmm... how GOOD a friend 3 doors down is s/he?  ...id suggest popping their xbox on your connection for some testing


    maybe someone else here can be a little more helpful
  • Re: Please Help...Game Lobby Closed Error.
    ohlin5
    @Phr057:

    I tried this and I think I have it setup right, because my computer can still access the internet just fine.  However, when I go over to my xbox I can "connect to live", but when I go to the "test xbl connection" it gives me an error about having too low an MTU setting, which is why I put the xbox in the DMZ in the first place...

    EDIT:  I also wanted to let you guys know that most times I search for games I fine somewhere around 20, give or take...
  • Re: Please Help...Game Lobby Closed Error.
    welcome to the newest game by IW...Yes its broken and yes it was rushed...Hopefully IW will fix everything now they are back from the extended vacation.
  • Re: Please Help...Game Lobby Closed Error.
    ACiDiCACiDiCA
    oh crap  ... ive had the 'too low an MTU setting' error before ... im sure it will come to me what i did
  • Re: Please Help...Game Lobby Closed Error.
    Has nobody noticed what his upload speed is? That is horrible. I believe your problem lies there. Your connection is timing out to the host; causing a ton of lag and eventually disconnecting. You really don't have many options there, besides an upgrade, which sounds to not be an option.
  • Re: Please Help...Game Lobby Closed Error.
    ohlin5
    That sounds all well and good, but the problem is that when I can join a game it works great.  95+% of the time it's lag-free and it plays wonderful.  The problem is when I can't join a game.  I am convinced this is a problem on IW's end because, as I stated in a previous post, I have tried everything and my neighbor down the street has an even slower connection and he never has this issue, so as far as I can see that can't be it.  I realize I have a slow connection but I am pretty sure this is IW's issue.
  • Re: Please Help...Game Lobby Closed Error.
    PalZer0
    Bumping this because I'm having a similar issue and I think it might have something to do with the Xbox Live party chat restrictions.

    I only get the "Game lobby closed" errors when I have my headset plugged in and I try to join a game in progress. This problem isn't specific to any particular playlist either as it occurs on all playlists.

    I've sent multiple @fourzerotwo tweets regarding this issue and he hasn't even acknowledged them (or anything else from me for that matter).
  • Re: Please Help...Game Lobby Closed Error.
    EvanMyspace
    if you have a linksys router maybe try this?

    <!-- m --><a class="postlink" href="http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/Xbo x_Live_360.htm">http://portforward.com/english/routers/ ... ve_360.htm</a><!-- m -->

    not saying it will work. but it worked for me,a friend, and another guy on this forum.

    just a little help. other that that. idk
  • Re: Please Help...Game Lobby Closed Error.
    PalZer0
    My NAT type says "Open" in MW2 and the XBL connection test passes without any NAT issues as I already have the appropriate ports forwarded in my Linksys WAG54G2 (UPnP doesn't work on that for some reason even if it's on).