13 Replies Latest reply: Jun 16, 2012 4:41 AM by DerpDerpinson RSS

This Game is Currently Unavailable

Every single time I want to run mw3 multiplayer, I have to prompt Steam to verify the game cache. I have to do this even if I am unable to get into a game. If the program starts, the next time I try to run it I will get the message "This game is currently unavailable. Please try again at a different time." Then I verify the cache, Steam downloads something, and I am able to play one time. I'm not the only one having this issue. The only modification I've done to the game is renaming a file to remove in-game music. I'm hoping not to have to reinstall. What's going on here, and how do I fix it?

  • Re: This Game is Currently Unavailable

    I got the same "The game is currently unaviable" "bug" every time i try to start it.

    If the game starts i get a 5minutes blackscreen and if i join a server the loadingscreens needs over 5minutes to load a level.

    • Re: This Game is Currently Unavailable

      I have the same error, i just bought MW3 on steam, and i get "This game is currently unavailable. Please try again at a different time." If i click verify integrity it solves the problem for one play, but it takes 5-10 min. So i have to wait 5-10 min EVERY time i want to play? Are f****ing kidding me?

  • Re: This Game is Currently Unavailable

    Same error... Broken game

  • Re: This Game is Currently Unavailable

    I found it on Steam, worked for me:

     

    "Ok I searched the internet and the forum for this problem and did not find a fix. Verifying the cache files get me back in but everytime I got out of the game it was the same thing everytime I started up the game again. So here's the fix. Either when there was an update or something it changed the file IW5MP.exe to

    IW5MP.exe.old and when it was done with the update it either didn't create a new IW5MP.exe or didn't rename the file back to IW5MP.exe. So go to

    Program files(x86)\steam\steamapps\common\call of duty modern warfare 3. In that folder you should find the file

    IW5mp.exe.old. Rename that file to IW5MP.exe. Close the folder start your game and the problem is gone. Hope this works for you. It has worked for me and 2 of my friends"

     

    Thanks to Kidstone

    • Re: This Game is Currently Unavailable

      didnt work BECAUSE II HAVE AN IW5MP.exe -.-

      I got an blackscreen and 10 mins waitingtime.

      Not an fullcrash -.-

      learn to read

    • Re: This Game is Currently Unavailable

      Sadly I do not have the .exe.old file, just the one I ought to have so this solution is not an option. I read somewhere that if you tell it to verify the game cache, then shut down and reboot steam without playing the game, it may work for good. I'll try that and post what I find.

       

      Riucario don't be rude he's just trying to help, and your problem sounds different than mine in the original post so if you want help with your particular situation maybe start a different thread - but definitely don't be rude to people who are trying to be helpful.

    • Re: This Game is Currently Unavailable

      Thank you for posting it here and Kidstone, That worked perfectly... I just went through support and all they told me was to verify the files and that's it and if that didn't work uninstall and reinstall or wait for a newer update... but here's the thing I verified, and restarted steam and my laptop 3 times today within a 2 hr span...

       

      anyways here's something that might be part of the issue, I just bout the DLC collection 1 and I didn't have this issue before today...

  • Re: This Game is Currently Unavailable

    This solution wound up working for me:

     

    Verify the game's cache in steam via right click on MW3 - properties - local files - verify integrity of game cache. Allow it to finish and do whatever it needs and, without running the game, restart Steam. Been working fine for a day after doing this. Hopefully this helps.

  • Re: This Game is Currently Unavailable

    I get this every time I click on the icon. But the second time it runs without problems ... sometimes the character in the game won't move and I have to restart several times ...