9 Replies Latest reply: Jul 12, 2013 3:39 AM by C0nf1dence RSS

Can't sprint or throw grenades - PS3

Guys, I can't sprint or release grendaes once they're pulled.  It's not the controller, have checked MW3 and L3 all working ok.  Happens in Campaign as well as Multiplayer.  Have rebooted a few times, same issue.  Have tried different stick layouts. 


What's going on???

  • Re: Can't sprint or throw grenades - PS3

    OMG finally!!! Someone else who is having the exact same problems that i am!!!


    When i press L3 i'm unable to run at all... instead, my player motions to throw a grenade, the target crosshairs appear, but the grenade never releases. If i press L3 again, my player then throws the grenade. I'm never able to sprint/run when pressing L3. Also, when i press L2 or R2, nothing happens at all. My Stick Layout and Button Layout are both set to Default. I played MW3 to see if my controller was going bad but my L2, R2 and L3 functions work perfectly on there. I then played my Black Ops 1 disc and the same exact issues occured on there! For my last work-around... i took my Black Ops 2 game back to GameStop to get another new one. I got home, threw it in, and the problems continued. This is the first time i've ever experienced anything of this magnitude on any of the Call Of Duty games.

  • Re: Can't sprint or throw grenades - PS3

    I have the same problem as well! My game worked perfectly fine for about 2 days before this occurred. I too have made sure my controller wasn't the source of the problem, as my L3 button and grenade buttons work fine when playing other games. I've also tried a different controller. I've tried different button layouts. I've erased my game data. I've tried turning my controller off and then turning it back on. I even took my copy of the game back and exchanged it for a new copy. Still nothing. This is really starting to drive me crazy. I hope that they fix this issue soon. I didn't pay $65 for a game that doesn't work, and if this issue isn't addressed soon, I'm going to take my (2nd) copy back to the store and get my money back.

  • Re: Can't sprint or throw grenades - PS3

    Alright guys, I figured it out. The problem is caused by R2 and L2. Pull them up, push them in, and repeat. This actually solved a glitch I had with Netflix, and ended up resolving this problem for Black Ops 2. Hope it works for you guys. I know it was miserable to deal with.

  • Re: Can't sprint or throw grenades - PS3

    I just had this happen out of the blue.


    The fix mentioned works as well!

  • Re: Can't sprint or throw grenades - PS3

    Well... I don't know if it'll work for others but I simply did this. Press R2 to bring up the grenade, pause the game and if it works, the grenade will be released. After that, just unpause the game and everything should start working properly. I randomly got hit with whatever this is: a glitch or whatnot, and I just tried this out of sheer curiosity. Hope this is helpful.