21 Replies Latest reply: Dec 30, 2013 3:41 PM by OGHuxtable RSS

My swap force portal doesn't work!

tahititam

Hello just bought a swap force starting kit for my godson for his wii, we plugged it and nothing happens, on the screen it keeps saying to put a skylander on the portal! but when we do it nothing happens!

we tried the third generation skylanders on the former portal (spyro's adventure) and it worked, so we don't thing there's a problem with the skylanders.

Is there a way to fix it?

  • Re: My swap force portal doesn't work!
    PortalDisconnected

    Hi. I have an issue with the portal, too.

     

    The Swap Force game, running on XBox 360, complains "Portal Disconnected" even though the Portal is connected via USB to a functioning USB port. The portal lights up, indicating it has power. Meanwhile, the original Skylanders portal works without any difficulty connected to the same USB ports. We've tried several of the USB ports on the XBox, but we still get the error every time. This is our first time trying to play Swap Force. Needless to say, this is disappointing. I've searched support forums and find no matches for this problem. I guess the portal that came with the new game is bad?

  • Re: My swap force portal doesn't work!
    clayc3466

    We got my son swap force for the wii for his bday. The portal wouldn't work at all. We called activision and they sent us a new one bc it's under the 180 warrantee. The new one now lights up but still says to connect the portal. We have giants and it works fine. Very frustrating!

    • Re: My swap force portal doesn't work!
      OGHuxtable

      Hi Clayc3466,

       

      Do you have any other portals near the one you are experiencing an issue with?   Is it near any wireless devices?  Also, please be sure the cable is not bound.

       

      Let us know if you are still experiencing this issue.

       

      Regards ^AH

       

      *Update

       

      Clayc, I'll send you a direct message.  Please be sure to check your inbox.

  • Re: My swap force portal doesn't work!
    SkylandersTrouble

    At beginning of Swap Force game it says I have to unplug other portals.  No other portals are plugged in and the batteries are out of the old Skylanders portal.  I have turn the Wii U off unplugged the portal and turned game back on and replugged the portal and it still says to unplug other portals.

    • Re: My swap force portal doesn't work!
      LauEJ

      My son got this game for christmas, however we have been unable to get to work due to the error message - THERE ARE TOO  MANY PORTALS PLUGGED IN.

      There are no other portals plugged in and we have tried turning off unpluggling and re starting. I took the game back to the shop today and asked for some advice but they said there must be a faulty cable so exchanged the starter pack but this one does exactly the same thing! Very frustrating.

       

      Please could I have a resolution on how to get this too work?

       

      Thanks

  • Re: My swap force portal doesn't work!
    PleaseSupportFrank

    Having the exact same issue and no response / reply from Activision despite a support and return claim. Did you ever get this resolved? I have sad children after Christmas which is not cool Activision.

    • Re: My swap force portal doesn't work!
      OGHuxtable

      Hi Frank,

       

      The last thing we would want is unhappy children during the holiday season.   You mentioned a warranty claim in your post.  Can you please send me a direct message with the claim number and details of your issue?  I'll find out more information on the status of your claim.

       

      Apologies for any inconvenience this may have caused.

       

      Regards ^AH

  • Re: My swap force portal doesn't work!
    Rascals999

    Same problem. Portal turns on but does not recognise any sky launderers, new or old. Activision website is rubbish, no email support, just a number in the US! Expensive call from UK. Kids v disappointed. Refund I think. :-(

  • Re: My swap force portal doesn't work!
    nononever

    We are having the same problem. We can get 2 of the 16 characters we have to work and then only sometimes. Very disappointed. Makes for a lousy Christmas.

    • Re: My swap force portal doesn't work!
      OGHuxtable

      Hi Nononever,

       

      Can you please specify which platform you are on?  Also, indicate which characters are not registering on the portal and if it only occurs in certain areas of the portal.  Do they not register on the portal while playing Swap Force or another Skylanders game.  Here is an article showing toy compatibility Activision Support

       

      Regards ^AH

  • Re: My swap force portal doesn't work!
    wiinovice

    Hi,

    I have the same problem when I connect it to a Wii console. Both USB ports seems to be working since my son can play with Giants (wireless) portal when it is connected to either of the ports.

    I disconnected the Giants portal (and turned it off), unplugged the Wii console, waited 2 minutes, turned the console on again and attached the Swap Force portal. After the initialization, I got the message Portal not connected.

    Very frustrating.

  • Re: My swap force portal doesn't work!
    nupod

    Same here as well on the Wii U Swap Force Portal. It worked on day 1. On Day 2 it started saying place skylander on the portal every 2 minutes even though the skylander was already on, then stopped recognising the skylanders altogether. Tried 40+ skylanders - none recognised, tried different USB port. Checked for dead spots - nothing. So one child in tears that his christmas present doesn't work. Submitted a case - but no details on how to return the portal. Seems pretty unfair to have to wait for that, wait on Activision receiving the faulty portal, then wait up to another 10 days to get a replacement. !! Have both Spyro's Adventure and Giants as well.... but won't be getting any future skylander releases after this experience.