2 Replies Latest reply on Nov 15, 2013 9:50 AM by Tzivya RSS

    Skylanders Lost Island Activate save corrupt?

      I updated my game a few nights ago, and have not been able to access it since then. When it tries to connect to Activate to download my save, I get:


      Retry Download


      Kaos is at it again and has caused a problem with your download. Please check your connection and ensure you have enough storage space on your device.


      I assumed at first that it was indeed a problem with the download, so tried the usual troubleshooting steps:


      Closed all apps and tried again

      Reset device and tried again

      Redownloaded the app and tried again


      I also tried a rather extreme combination of the above where I restarted the device between every step I could (Downloading the app, downloading the first bit of content, downloading Activate info) and that did nothing.


      To see if it was a problem on my device or with Activate/Activision's side, I installed the app on a spare iphone that had never had the app on before. I went through the tutorial, and then logged into Activate to access my save. As soon as it recognised my password was correct, it briefly went to 'downloading data' and then immediately to the same error I get on my ipad.


      Clearly at this point it is not something on my end. I am sad because this means I will most likely miss this weekend's events, and since I signed up day one of the app and have put way more than I care to admit into it (Well over a hundred and fifty, not counting the actual figures we own), I was looking forward to it as something I've been with  long enough to celebrate!


      Anyway, my email address is jamie.norwood@gmail.com and my Activate username is Tzivya. Please help, and hopefully before the weekend, I really want to see what's on offer and maybe pick up anything I managed to miss along the way (Though I am not sure there is anything! I've been distressingly completionist. Really, I'm your ideal customer. Please help. )