3 Replies Latest reply on Jan 4, 2014 2:25 PM by Quim RSS

    Spongey lag since before Christmas

      Hi Ghosts support. Recently, I have mega lag. It doesn't seem to affect my scoring cos I'm still bumming people but it's disgustingly spongey compared to how it used to be and makes the game tiresome. Before you ask, the lag is not sown to my connection. I work for my ISP at the top level of support and I have done all the usual checks so I know it is not my connection or hardware at fault. I suspect it is lag compensation. You guys fiddle with it every time the version number in the bottom right of the screen changes, and I notice every time. Now I'm not expecting you to fix lag compensation for me, but I was hoping you could confirm this. The problem started a few days before Christmas. Is this when the version was rolled out?

        • Re: Spongey lag since before Christmas

          Hello Quim,


          There seems to be some confusion here. This sounds a lot just like normal lag. I know you stated you went through all of the "normal checks" but if you wouldn't mind me taking you through my own check list, then we can see whats going here.


          First off, can you let me know if you are playing from a wired or wireless connection?

          Run a speed test, and let me know the results: Speedtest.net by Ookla - The Global Broadband Speed Test

          If you have not yet set port forwarding, do so now: Activision Support


          Lastly, have you attempted to remove all of the game updates and see if the problem persist? Obviously you need the most up to date version to play, though for testing purpose's, I wanted to see if you encounter this lag without the updates.




          ATVI Support

            • Re: Spongey lag since before Christmas

              First of all, there is no confusion on my part:


              1. I have not asked for any help fixing this issue. I am almost certain the issue I am suffering is due to lag compensation. I am 100% the issue I am suffering is not down to my connection. All I have asked for is confirmation of when the version of multiplayer was rolled out.


              2. The issue I am suffering is due to latency (what adults call lag) rather than speed. So, in future, if you want to be helpful you should ask for pingtest.net results rather than speedtest.net. Although both of these sites are actually unreliable (today I got a result of 25Mb/s down on one server and 75Mb/s down on another), if you run a few tests to different servers you can get a good idea of your connection's characteristics. My max speed is 75Mb/s down and 18Mb/s up. Ping Avg 21ms Max 24ms Min 20ms. That means jitter is 4 ms. Obviously all these results are relative to the server I was connecting to and may not be reflective of actual online experience. So, I have pinged a friends router. Results were Avg 26ms Max 28ms Min 23ms over 500 pings. That means jitter is 5ms. We were also simultaneously playing 1 on 1 and it was still spongey and we were both seeing around 250ms of lag. This means the connection between each of us was tested as good while we were playing, but both of us suffer laggy spongeyness. Given that my friend doesn't normally have a problem with this unless we are playing against each other and I have had this problem constantly for a week or so, it means that we suffered this latency because of lag compensation applied to my connection. We tried on my host and his host, same problem.


              3. If you delete updates and try to play a game you are automatically signed out of Xbox Live and are not able to sign back in until you have the latest update. You should know this. I have already uninstalled the game and updates and had them redownloaded (remember the part where I said I have done all the usual checks?) but that didn't help either.


              4. I don't need to forward ports on my router as NAT is open already. Just to tick a box, I have also tried with a spare router and forwarded ports. NAT type is always shown as open in the game AND most importantly, improper NAT configuration 100%, absolutely does not cause lag or latency, it just means you cannot connect to certain other hosts at all.


              5. I have also tried another Xbox with and without the game installed, multiple ethernet cables (some were crossover, some straight through although it doesn't make any difference these days anyway unless you have a business grade Cisco router or switch), my router is directly connected to my modem and that is connected directly to the SSFP on my NTE. The SSFP has been swapped (just in case you know what any of that means).


              As you can see, I don't need any help determining whether my connection is at fault. I just need you to tell me when the update to was released?


              P.S. Looks like I've just answered my own question. Latest title update was released 23/12/2013 found here http://community.callofduty.com/thread/200800959#.Usc6jdJdUmk


              So, I may as well ask... How do I fix this (by this I mean if I add artificial latency or spoof in some way will my connection improve)? I have to assume this happens to other people so why are good connections sometimes over-compensated when lag compensation is applied? I've had less lag when playing Australians. I have sooo much latency at the moment and my connection is proven to be pretty damn good. I play on friend's consoles on standard ADSL and they have nowhere near the latency I have. What is going on?