[I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

Black Ops II Technical Support

Re: [I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

in reply to YoAverageGamer

Ok sorry for bumping but found this thread and wanted to share the solution

1 of your maps have been corrupted for me it was nuketown so it annoyed me during the nuketown weekend. If you play the map first the map after it will give you the error redownload ALL of your maps

hope i helped

Level 1
Likes: 0
Posts: 1
Registered: ‎16-07-2011

Re: [I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

in reply to YoAverageGamer

This needs to be resolved seriously!! I haven't played i over two months, but my step-son tried to play and there was a new update?? So of course that update loaded...I have played a hand-ful of games and suddenly I got that error again.  FYI...I even bought a new CD a few months back with no scratches. so that cannot be the problem.  It happened the first time immediately after an update back in April or so...and since then I have not been able to play until the most recent update.  However now some maps go flourescent?? Not sure if this is new or what.

Level 1
Likes: 0
Posts: 2
Registered: ‎20-06-2013

Re: [I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

in reply to Lohrke_IV

Hi Lohrke_IV, if the problem occurs on DLC map pack,

Try loading each and every map in multiplayer offline.

If the problem only occurs on DLC map packs, Have you tried tyfgyl's solution of deleting all DLC map packs and redownload them?

Also you may try install to hard disk. Problems reading game disk might might be something wrong with console which might be optical drive going out.

Level 2
Likes: 4
Posts: 53
Registered: ‎28-05-2013
Highlighted

Re: [I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

in reply to YoAverageGamer

Same thing happens to me exactly the same and sometimes it lets me join and when i do the map is like nightvision one part is black and like glitched up idk and it just doesnt work

Level 1
Likes: 0
Posts: 3
Registered: ‎01-03-2014

Re: [I WANT ANSWERS] "Downloadable content has changed: storage device has been removed" Game Error!

in reply to YoAverageGamer

You want answers?

You want answers?!

You can't handle the truth!

"At the end of the match, there remains only ... nuttin 2 say."
Level 62
Likes: 3467
Posts: 6218
Registered: ‎24-05-2011

Studios