Unhandled exception solved!!!!!!

Black Ops forum

rakkasan2 wrote:

 

This is for users using windows XP, and realtek audio. Even if you're not using these specs, give it a try, it worked for me.



Go to the Control Panel> System> Go to the Hardware Tab and click "Device Manager".



Now, scroll down the list and find Sound, Video and Game Controllers. Then, right click and DISABLE "Unimode Half-Duplex Audio Device".





***If this works for you, bump the thread up so others can see it, as we've noticed there's little to no support thus far. I tried everything from Sound drivers, video updates, DX updates and this is what worked for me.



Happy Fragging!



WinXP SP3

8300GS

Onboard Realtek HD audio







This still aint working for me, i go there and i dont see a "Unimode Half-Duplex Audio Device"
lawnjanx
Likes: 0
Posts: 1
Registered: ‎28-10-2008
Same.
GrizMartin
Likes: 0
Posts: 6
Registered: ‎21-10-2008

Kronos_9326 wrote:

 

Try this, it worked for me and a few other people so far at least:



Okay, download directx Redist (google it for a download source) It is kinda big (about 80mb). (Probably should not overwrite anything, if gives option, try a different folder)



Unzip and put the contents into C:\WINDOWS\system (or maybe even system 32, I put it in system)



Then, download/move the DXSETUP.exe into the SAME folder that you have the REDIST files in.



RUN the DXSETUP.exe



Wait for it to complete, and then start up your game... It might take awhile for it to start up. A Cinematic will show, and then the player profile creation screen... At the main menu, it froze (for me) but may not for someone else.



Hope this helps. Tell me if it works, and tell me if I am not clear enough.



This worked for me, it hangs at a black screen for a few minutes then loads to the profile page. I was just playing multiplayer for ten minutes with no problems.
Havock77
Likes: 0
Posts: 1
Registered: ‎29-10-2008
I tried almost all of the solutions posted but came across another one I haven't seen here and it worked for me.



In "Sound and Audio device Properties" click Advanced under Speaker Settings

then go to the Performance tab and change Hardware Acceleration to full

and Sample Rate Conversion Quality to good.



This got me around the unhandled exception error. I got the black screen but if you wait 4-5 minutes, the game will start.
Bosty
Likes: 0
Posts: 4
Registered: ‎22-10-2008
didnt work for me... :/
TypeSiR
Likes: 0
Posts: 1
Registered: ‎29-10-2008
Highlighted
I did everything I was reading here, new videocard drivers, new audiodrivers, moved all the slides I could find in my audio options, but still the same error.

I hope Activision finds a fix or else I won't be buying cod5, even though my heart is bleeding when I type this.
SkyZip
Likes: 0
Posts: 2
Registered: ‎29-10-2008

SkyZip wrote:

 

I did everything I was reading here, new videocard drivers, new audiodrivers, moved all the slides I could find in my audio options, but still the same error.

I hope Activision finds a fix or else I won't be buying cod5, even though my heart is bleeding when I type this.







same here mate they better fix this soon
geordeh
Likes: 0
Posts: 1
Registered: ‎29-10-2008

GrizMartin wrote:

 

I do have a sound card.



You're screwed.....
GreyGhost531
Likes: 0
Posts: 2
Registered: ‎24-10-2008

Bosty wrote:

 

I tried almost all of the solutions posted but came across another one I haven't seen here and it worked for me.



In "Sound and Audio device Properties" click Advanced under Speaker Settings

then go to the Performance tab and change Hardware Acceleration to full

and Sample Rate Conversion Quality to good.



This got me around the unhandled exception error. I got the black screen but if you wait 4-5 minutes, the game will start.





Worked exactly as you said. I did this and mine finally worked. PASS THE WORD!!!!!!!!!!
GreyGhost531
Likes: 0
Posts: 2
Registered: ‎24-10-2008

Crash.eX wrote:



Code: Select all

Error during initialization: Unhandled Exception caught





If you get the above error when you launch the game, try one of these



solutions to correct the problem:



* Vista

o Go to Control Panel

o The click on Hardware and Sound

o Click on Sound

o Double click on Speakers

o go to the Advanced tab

o Set the default format to 24 Bit, 48000 Hz (Studio Quality)

* XP Method 1

o Go to Control Panel

o Click on Performance and Maintenance

o Click on System

o Select the Hardware tab

o Click Device Manager

o Select Sound, video and game controllers

o Right click on Unimodem Half-Duplex Audio Device and select Disable



* XP Method 2

o Right click on My Computer,select Manage

o Click Device Manager

o Select Sound, video and game controllers

o Right click on Unimodem Half-Duplex Audio Device and select Disable



I also found someone that resolved this on XP by



reinstalling/updating DirectX. It may be worth a try (and beneficial to



have the latest version anyway) but it did not resolve the problem for me.



If you wish to try it, you can download DirectX from here:



http://www.microsoft.com/downloads/Browse.aspx?displaylang=en&categoryid=2





This worked for me yesterday guys hope it helps you
Mongrell
Likes: 0
Posts: 5
Registered: ‎27-10-2008

Studios