Disconnected from Host Constantly

Call of Duty Black Ops 4 PC

I can't seem to get even through one game anymore.  I didn't have this problem at launch it started getting worse now it's almost comedic how bad it has become.  My NAT is open, I'm on a wired connection 1g line, no other game does this.  I get a few minutes into any mode and then I get Connection Error where I can still chat but cannot move, I am however able to be killed, which is what usually happens since I'm stuck in place or I randomly teleport to places on the map.  I get error numbers from 750, 1500, 15500, and some others.  I can't even count the number of times this week alone I've not finished a match, 4 times today already.  Am I the only one with this issue?

TheDevilsLettuce#1405476
Likes: 0
Posts: 5
Registered: ‎17-03-2019
7 REPLIES 7

I'd do a few things here, first clear the cache and reinstall Battlenet https://support.activision.com/articles/en_US/FAQ/Deleting-Old-Files-from-PlayStation-4-and-Xbox-One...

 

Next, flush your DNS in Windows run your CMD, type ... ipconfig /flushdns and reboot your Router and then PC.

 

Lastly, temporarily disable any firewall(s) on your PC and Router. BTW you can only have one (1) DNS server. Example if you have your ISP modem / router and your own Router a double DNS can cause all sorts of connection issues. 

Momba1
Likes: 454
Posts: 3270
Registered: ‎28-12-2012

Thanks for the insight, but no luck, today now it says critical error disconnected from host.  The only thing that seems to work is to play one game leave the lobby then get into a new lobby.  As long as I bounce around no issues, but if I stay in the same lobby then 2nd game always disconnects about a minute into it.  No other game I own does this, including COD WWII.  

TheDevilsLettuce#1405476
Likes: 0
Posts: 5
Registered: ‎17-03-2019

Im having similar isues. However, I dont even get to play the game. As soon as game connects to servers it disconnects.  This started to happen within a couple of weeks. The it started happening randomplyand now it wont even connect for 2 seconds. Just got the game to and this is just a horrible experience.

Liquidus1974
Likes: 0
Posts: 2
Registered: ‎22-03-2019

I don't have the issue. If the Cache is cleared and Battle.net App has been reinstalled .. it leaves one thing .. reinstall the game, last I checked 89 GB. This assumes your one (1), never 2, Router is set up properly, your firewall isn't causing problems (test by disabling) nor that you have some AV causing an issue (test by disabling). 

 

Test the quality of your connection http://www.dslreports.com/speedtest

Momba1
Likes: 454
Posts: 3270
Registered: ‎28-12-2012

Disabled firewall, only one router, wired connection to said router, cleared Cache, reinstalled, battlenet, as well as the game, still does it.  Shut down Antivirus software, force stopped every program not needed to keep my system stable, still does it.  No other game does it.  Guess its just my luck, I can play endlessly as long as I leave the lobby after each game and search for a new one, but that stinks as a solution especially when you get a decent group in a particular lobby.   

 

https://www.youtube.com/watch?v=8z3kn0ebaJ8

 

 

TheDevilsLettuce#1405476
Likes: 0
Posts: 5
Registered: ‎17-03-2019

I noticed it's a Notebook, next disable WiFi and make certain that your WiFi and Ethernet are not Bridged. 

 

Run MSCONFIG, click on Services tab and then check Hide all Microsoft Services, and uncheck everything. Then click on the Start-up then Disable everything. Restart and test again. 

 

Lastly open a Chat with Activision https://support.activision.com/contact_us

 

They may have more information.

Momba1
Likes: 454
Posts: 3270
Registered: ‎28-12-2012

I've given up, yesterday it worked for about an hour without issue, then it started dumping me right after joining a lobby, if I got into a game it dumped me within the first minute.  today I can't even make 30 seconds.  I'm moving on, thanks for your help but this game for some reason is broken for me, stinks I shelled out 120.00 for it, but isn't the first game I wasted money on, won't be the last I'm sure.

TheDevilsLettuce#1405476
Likes: 0
Posts: 5
Registered: ‎17-03-2019

Studios