Cod Ghost app not working!!

Ghosts Clans Discussions

Hey i dont know but the second screen doesnt works for me what do i do please help me i thinks is the app

Likes: 0
Posts: 1
Registered: ‎21-05-2014

Haha I hate iPhones personally. Too many issues. Maybe the app was under maintenance? Try again and see if it works.

Likes: 5
Posts: 18
Registered: ‎07-07-2014

Thats the same for me. its not working. it says Loading then it just has the ghosts backround and stays there

Likes: 0
Posts: 1
Registered: ‎18-09-2014

I Found that the app is constantly telling me that it's currently under maitenance, oh how I hope so! I have tried signing in multiple times and it comes up with an error, it gets frustrating

Likes: 0
Posts: 1
Registered: ‎07-11-2014

The COD app stops working months before COD: AW releases. When I log in to it, app keeps saying "No internet connection". Oh boy, I think of it as a dead boy now. You guys may never see this guy up and running again. They left it.

Likes: 0
Posts: 3
Registered: ‎31-10-2013

I am trying to change my clan name but it keeps giving me "invalid name."  I know there is no other clan with the name I am trying and there is nothing derogatory in the name.  Why can't I change the name?  Someone please help.

Likes: 2
Posts: 2
Registered: ‎03-06-2014

App doesn't work anymore it keeps prompting service unavailable.

Likes: 115
Posts: 766
Registered: ‎21-06-2011
Likes: 2
Posts: 23
Registered: ‎12-11-2014

it has never worked for me and i have tried several times over the last few months.  it finally did something today when i tried to open it, but all it did was redirect me to the app store to the AW app.  which i am sure will not work either and i don't even own AW.  why should i buy it if the app probably won't work and i won't be able to join a clan?  why build the game with clans in mind if we can't use the features intended?

Likes: 0
Posts: 1
Registered: ‎23-12-2014

Yes the Call of Duty Ghosts app is NOT working now on my Android 4.1+ (4.4 os) based mobile or tablet devices. It worked about 1 month ago. At that point when I downloaded and edited our clans details. But now the Ghosts App upon attempting to login redirects me to Google Play store to download...get this...Advanced Warfare. But I already have the Ghosts app and the Advanced Warfare app. Go figure.

Then the Advanced Warfare app doesn't work either. It shows that no multiplayer matches have been played by my PSN profile. Are you kidding me?

Likes: 1
Posts: 11
Registered: ‎17-04-2014