disc read error message for the invasion map pack on ps4...tried deleteing and reinstalling, rebuilding database, restoring lisences, ps4 is primary...i dont get it

Ghosts Support Forum


I just a brand new ghost disc with zero marks, scratches, or burns.  I bought the invasion map pack an downloaded/installed it with no issue but when i go to play the new alien map or multiplayer maps i get black screened then a message comes up saying disc read error 'mp alien dlc3 load'.  I have been thought the steps with PS support and they couldnt figure it out.  I rebuilt data base, restored licenses, deleted and redownloaded, my ps4 is primary, and i have reset my connection multiple times.  PLEASE HELP

Likes: 0
Posts: 1
Registered: ‎17-07-2014

I have a suggestion. You may want to try downloading about 200mb worth of free contents from the PS4 then try to play the game again to see if there are any changes. I would also advise that you have your console checked on a near Sony service center.

Likes: 44
Posts: 393
Registered: ‎10-10-2013

If you are in a wireless connection, connect the console via wired and try to redownload the DLC again. You could also your game in a friends console to check if the same error with the Invasion DLC will appear on his console. If not, you may want to have the console checked with PSN.

It's not how I say it. It's how you understand it.
Likes: 170
Posts: 1132
Registered: ‎28-02-2013


A support case was created for you and you should be contacted shortly by a Customer Support Representative, if you haven't been already. You can view and update your case at the Activision Support website. After logging in, go to "My Support" then "My Cases".



Go to Activision Aces!
Community Coordinator
Likes: 1541
Posts: 8985
Registered: ‎04-06-2013