Can't play online

Ghosts Wii U

Ok so I come back to the game after a few months. I go to multiplayer, and it says I need to download the new content off the Nintendo eshop. So I'm like sweet we finally have DLC!

I visit the eshop, click on ghosts, and it says I'm not authorized to view this content, or something like that.


Likes: 2
Posts: 21
Registered: ‎01-10-2013
in reply to TargetFinderN00B

I think a few others had a similar problem to you a while back.

Call of Duty Ghosts online broken. NEED HELP!

Wii U-Unable to download Free Fall

Take a read of those threads.  It might be something to do with your region that you have set, or due to not having the correct rights because of settings in Parental Control.

Check first if Parental Controls are active and set on your console.  If it is then you're going to have to use a NNID that isn't restricted or getting the personal who set it up to give you access or download it for you.

If there are no Parental Controls configured for your Wii U then I would check those other threads for info on a possible problem due to region.  barA-ehT makes a mention in both threads about having a similar problem and fixing it by modifying his region.


For simplicity, I'll quote barA-ehT with the info that he gave.

barA-ehT wrote:

Hi, I had the same problem to download the free fall DLC too. I found out MY problem was related to the region of my Wii-U and nintendo network ID (south america in my case). Other users posted something like that on the support forum, and I explained them how to fix it, check my answer:

Wii U-Unable to download Free Fall

Thats how it worked for me anyways, try checking that and also your age thing. Creating a new user + a new nintendo network id with the right country/region and age may fix the problem.

barA-ehT wrote:

Hello there, I had the same issue last night but I figured out how to fix it, I think the problem comes from the eshop channel and not from Activision.

I am from south america, so in my console settings the country was Venezuela, when I created the user and the nintendo network ID it automatically puts the same country in your Wii-U settings for your nintendo ID. What I did was this:

1) Changed the country to USA on the Wii-U settings.

2) Create a new user.

3) Create a new nintendo network ID to that user. The system will automatically put USA as your country of residence on your newly created nintendo ID. Then validate your nintendo id with the link they send to your email address.

4) Start the game, and now you will be able to download the DLC (which is about 130 MB)

5) After downloading and installing the DLC (you need to go back to the Wii-U menu in order to the DLC be installed), go back to your old user (the one you normally play with) and voila, you will have the DLC installed.

Thats how it worked for me, I figured out the problem was the country.

Let me know if you have any doubt.

Likes: 125
Posts: 387
Registered: ‎31-01-2013
The same happened to me but with MW3 and without the Wii U
Likes: 0
Posts: 2
Registered: ‎05-12-2017