Player-controlled killstreaks using the wii remote

Ghosts Wii U

So recently I've tried using some assault player controlled killstreaks like the trinity rocket, helo pilot, loki, and gryphon. I'm a wii remoter and usually they work fine, but sometimes when I use the Loki or gryphon the wii remote cursor thing dissappears(the orange thing on the ground for the gryphon, blue for the Loki). It doesn't happen everytime, I think its happened maybe 4-5 times with the gryphon out of 20-25 uses and 1 time out of 4 with the Loki. Its really annoying because when it dissapears you can't aim anymore. My sensor is fine because after I exit out of the streak I can aim just fine. Has this happened to anyone else? Is it because I'm pressing a certain button or is this a glitch?

Another thing is that the helo pilot and trinity rocket do not seem to fire where I aim the cursor for some reason? Is this something I'm doing wrong or another glitch?

Likes: 40
Posts: 246
Registered: ‎31-01-2013

had this glitch/bug or whatever it is a few times already.

Likes: 14
Posts: 169
Registered: ‎30-11-2011

And that's why I use the gamepad for those things... true story... lol

Likes: 87
Posts: 700
Registered: ‎04-11-2011

I haven't tried the loki or gryphon yet.  Helo pilot has been great though.  I love that thing. I haven't had any problems with it yet.

Likes: 490
Posts: 4011
Registered: ‎17-01-2012