MW3 on Xbox One S (Can't download Terminal/"Free downloadable content is required")

Modern Warfare 3 Forum

Okay, so first I will explain the situation then I'll explain the problem.

I got an Xbox One S a few days ago and I bought MW3 yesterday. I installed the game even though I bought a disc because the game is backwards compatible, everything is fine and well until I go into multiplayer which when I try to go into any gamemode in multiplayer the game forces me to download some kind of content "Free downloadable content is required. Do you want to download it now?" 

And ofcourse I press "yes" as you would. I tried that and Xbox Live popped up with the message "There are no items available for purchase at this time." 

I did some digging and apparently this is a regional problem? Which doesn't make any sense at all. My account region is set to the United States I bought the game in United States and my Xbox One S was bought in the United States and set to the United States. I sat down with an Xbox/Microsoft respresentative for about an hour and a half and we tried every troubleshooting step and of course non of it worked and basically we got to the conclusion that it is a regional problem. So he referred me to an Activision representative which obviously until now they didn't answer my question. So here I am asking you guys, the community, what should I do?

CommanderYoni7
Likes: 0
Posts: 1
Registered: ‎23-06-2014
1 REPLY 1
 
mjrm-939
Likes: 0
Posts: 1
Registered: 3 weeks ago

Studios