Out of memory error; original Call of Duty 4

Modern Warfare Forum

Out of memory error; original Call of Duty 4

Hi Call of Duty community,

 

I've recently been unable to play the singleplayer campaign of the original Call of Duty 4: Modern Warfare. When I load up a campaign level, an error pops up outside of the game:

 

"Out of memory error. You are probably low on disk space."

 

The loading cutscene plays fine, but the game won't load the level at all, and I just get stuck on the cutscene until I tab out and close the error message, which closes the game entirely.

 

The problem didn't start straight from this error message, however. There was a lead up to this error. At first, I was able to load up and play the campaign fine; but the game suddenly started experiencing lag spikes that weren't present before. This continued on for about 2 missions, until I attempted to load up a third mission, at which point the aforementioned "Out of memory error" occured. I have since been unable to play the singleplayer campaign at all. Multiplayer still seems to work fine, judging from my testing.

 

From what I can tell, this error started happening around the same time that a similar widespread problem was happening to Call of Duty: Modern Warfare Remastered players, in which they get the same error message, but are unable to start up their game at all. Fixes have been popping up on the internet for COD: MWR, but I can't seem to find any documentation about this glitch for the original COD4.

 

Is this a byproduct of the MWR issue that has seemingly extended to the original COD4 as well, or is it something else entirely? I've tried the MWR fixes I've found just in case, but they don't work, probably since it's a different error that's affecting the game anyway.

 

I would be glad to furnish any additional information required if anybody has any idea of what's wrong. I am playing the PC version of COD4 on Steam.

 

Thanks in advance.

 

Julian

julian_lj
Likes: 0
Posts: 1
Registered: ‎20-02-2017
2 REPLIES

Re: Out of memory error; original Call of Duty 4

in reply to julian_lj

I get this error at the splash screen and the game won't even launch.  I also have found people complaining about this problem as far back as 2014, so I suspect it's a bug from the original MW4 that was never fixed.

WinterMute2121
Likes: 0
Posts: 4
Registered: ‎01-11-2018

Re: Out of memory error; original Call of Duty 4

in reply to julian_lj
Callybelly
Likes: 0
Posts: 17
Registered: ‎06-11-2018

Studios