1 2 3 Previous Next 166 Replies Latest reply: Jan 17, 2011 8:04 AM by Allix_2011 RSS

    Official "Infinite Loading" Problem Thread

      Hello,

      This is the official thread for tracking down the root cause of what some community members refer to as the "freeze."  In order to cleanly identify this problem from any others, I am calling it the "Infinite Loading" bug.

      Please refer to this video to familiarize yourself with the issue I am speaking about:

      http://www.youtube.com/watch?v=AjGeskta-lE

      If you are in a hurry just skip to the end during the host migration.

      Some ground rules. I am telling you right now that if you've come in here and act childishly or immature, rather than help, you will be wasting everyone's time. At best, you are going to get ignored. At worse, you are going to get booted from the thread, the forums, or both.

      What I care about right now is engaging the PS3 community directly in search of the root cause of this problem. I've done it with a small group of people for a bit, but am not making the kind of progress I was hoping for, so I am expanding the reach.

      I've seen this problem one time myself. It was not during a host migration, like the above video shows. It was during the game start-up from a fresh lobby.

      I believe that this problem will result in disconnects on the other side. The ones where the game shuts down and you get "Disconnected from host." I am not positive, but think they are related issues. I believe that some of the work that we did for the 1.4 update (coming soon, hopefully this week) will help some aspects of this.

      Frankly, I won't know how far we've come until more people can use the new update. We've never got the problem to happen with the 1.4 update in QA, but that doesn't mean it won't happen. Unfortunately, Sony doesn't provide a way to selectively offer the update to individuals or I would do that in heartbeat. It's all of you, or none of you. We opted for all of you.

      With the 1.4 patch around the corner, I felt like we could benefit from a direct thread. Especially so we can compare experiences both before and after the update.

      How to help:

      If you get this "Infinite Loading" bug in your game, ask any friends you had in the game at the same time what they saw. This will really help us understand if some users are getting this, while others are getting ... say ... dropped into Combat Training or Theater with a checkboard (missing texture) or end up back in a "temporary phantom lobby" with the "Game Lobby closed" message. If you got the "infinite loading" what did your friend in the game get?

      Are you often the host of the game because you have an open NAT and great upload/download speeds? We get conflicting reports from people if this only happens to the host (or would be host, during host migration) or happens to both hosts and clients.

      Were you in a party? Does it happen more or less if you are in a party. Does it happen more if you are the party host (as opposed to game host)? Does it happen more if you are party client. Game hosts and party hosts are unrelated. Be sure when talking about if you were the host, or not, you make the distinction.

      Be as explicit and detailed as you can. Re-tell the story of the entire game from start to finish. For example: I just turned my PS3 on. I booted and went to <Playlist>.  We voted for <MAP>. The host migrated in the lobby/in the game (or not).  The version number as seen in the top right hand corner of screen was <#>. (This last point will be really important to us to know if you were version 1.3, or 1.4 when it happened).

      Direct link, or better yet repost in this thread, any quality posts made elsewhere that contain the level of detail requested here.

      I don't care about rumors. I just want facts. Rumors steal time away from fact finding and debugging.

      Trust that this will work and please try and have some patience. The last time we did the same thing with the community we found, trapped, isolated, debugged and fixed major issues with party system on PS3, found the bug with the VOIP icons, and more.

      David 'Vahn' Vonderhaar

      Update #1
      If you don't know how to check your NAT type it is in the OPTIONS menu on the SELECT button. Open is best. Moderate is not that great.  Strict? All bets are off. A tutorial about how to change your NAT Type to be open is outside the scope of this thread, as I wouldn't know enough about your router/NAT, connection type, ISP, if you are wireless (or not) and so much more necessary. You can Google it and find great tutorials, however.

      Update #2
      I now have a repro case and a crash dump from both the infinite loading and the freeze infinite loading variant so I've locked the thread. The lead PS3 programmer is helping us debug the cause. Will update as I get more information about when we can provide a fix.

      David 'Vahn' Vonderhaar
        • 1. Re: Official "Infinite Loading" Problem Thread
          bemplit
          Don't know if this helps, but one match i was hosting, and getting beat up really bad.  I couldn't hit a target to save my life, was not able to connect on melee's, etc.  I decided to quit the match and try my luck in another lobby.  The subsequent "Host Migration" locked up my PS3 and i had to reset.  In all fairness, i did wait at least 10 minutes before resetting the console, and i noticed that it was running very hot (hot air pouring from the back of the console).

          Most of my issues seem to stem from hosting.  I have had literally 2 nights since launch that i've played without issue, the first of those two nights was after a heated call with Activison support, where they had me DMZ my PS3 to see if that resloved my issues.  It did, for that session, but the next night, i couldn't get a single complete match in, and i gave up after an hour and a half trying.

          I know this isn't supposded to be a ***** session, but i am realy frustrated with the game and the lack of timely updates.  If we the community are supposed to help, more threads like these should be offered.  And a beta program HAS to be established, as that is the only way you'll get valuable feedback.  I know because i develop software.
          • 2. Re: Official "Infinite Loading" Problem Thread
            SHANE523
            THANK YOU VAHN!!!

            I will give you my specifics then tell you what I noticed and what I heard from friends.

            120GB Slim
            15Mbps Download
            2Mbps Upload
            Everything is hardwired
            NAT = Open
            I am host, at least it seems, 75% of the time.

            The freeze which causes my reboot is during the load of the map from lobby and sits at "Awaiting other players" or a message close to that. The only option I have is to press the PS button and quite game. Then I get the 3 beeps and reboot.

            I have not noticed that if it is a common map, it doesn't seem to matter.

            While it is loading...
            I can hear people playing and talking but I do not know if they can hear me all the time. There have been occasions where I have had a response to my question of if they are playing.

            The room continues because my friends are still in the room playing so to answer another question yes we were in a party. In most cases 3 or more when the freezing occurs. I have played in a party of 2 where I did not freeze for a while. Now that I think about it I am not sure if it has frozen while the party was 2 but I am not 100% sure about this.

            I had a freeze last night, I believe I was the host BUT I believe it was a "new" room due to the fact that I don't remember seeing any scores before launch. There were 3 in the party when this happened. The other 2 continued to play.

            It would help us if there was an indicator in the lobby to let us know who is the host. This would help us troubleshoot for you a little better.
            • 3. Re: Official "Infinite Loading" Problem Thread
              bemplit
              As a follow-up, my config is as described below:

              PS3 Slim
              250GB HD
              Cat5e directory to Linksys e2000 Router
              Comcast Cable Internet - 20mbps down/3mbps up
              PS3 has static IP in the DMZ on the router
              • 4. Re: Official "Infinite Loading" Problem Thread
                davidlsofferman
                This just happened to me on Saturday. I was in a party of two, we joined a fresh lobby of domonation and the people voted of Radiation and when it was at the very end of the loading bar, I had been stuck in the loading screen  for five minutes and nothing. So I restarted my PS3 and under my friends name it said "Playing Domination on Radiation".
                • 5. Re: Official "Infinite Loading" Problem Thread
                  Brian.+
                  Hey Vahn! Well I haven't had too much experience with this "infinite loading" problem but my friends did last night. We went into a game of Sharpshooter. The map was loading and then both of my friends that were with me at the time had this problem/error. They both had to restart their PS3's. But everyone else including me were still able to play. They both also have a wireless connection, not sure of their nat types. Unfortunately I was not paying attention to the screen, so I am not sure if it was migrating host's.
                  • 6. Re: Official "Infinite Loading" Problem Thread
                    CruelRuin
                    I've never had the problem in the video, but my system still freezes for reasons otherwise. Usually if host migration fails or takes too long I get booted back into the lobby. However when I try to take invites through the in-game menu system I constantly freeze. I don't know if this is related but this is the only time my PS3 freezes. It has become so bad that I strictly use the XMB to take invites.
                    • 7. Re: Official "Infinite Loading" Problem Thread

                      SHANE523 wrote:

                       

                      THANK YOU VAHN!!!

                      I will give you my specifics then tell you what I noticed and what I heard from friends.

                      120GB Slim
                      15Mbps Download
                      2Mbps Upload
                      Everything is hardwired
                      NAT = Open
                      I am host, at least it seems, 75% of the time.

                      The freeze which causes my reboot is during the load of the map from lobby and sits at "Awaiting other players" or a message close to that. The only option I have is to press the PS button and quite game. Then I get the 3 beeps and reboot.

                      I have not noticed that if it is a common map, it doesn't seem to matter.

                      While it is loading...
                      I can hear people playing and talking but I do not know if they can hear me all the time. There have been occasions where I have had a response to my question of if they are playing.
                      *SNIP*
                      .



                      I have had my share of infinite loading lockups.
                      http://twitpic.com/3cavc8

                      120GB Slim AND 60GB "Fat" PS3 (it's happened on both of them)
                      25-30Mbps down
                      5-8Mbps up
                      Hardwired through Netgear router
                      NAT = TYPE2

                      As you'd expect, I end up being host quite often due to my high bandwidth. I'm a solo player and do not play in a party... and as Shane523 mentioned, while waiting, I can still hear the voices on the other end and sometimes hear the game going on through other players who have mics on. I eventually hit the PS button and quit the game (and the system does the 3 beeps and reboots).

                      Thanks for taking the time to figure this out, Vahn.

                      -S

                      (PSN ID - shibiwan)
                      • 8. Re: Official "Infinite Loading" Problem Thread
                        Djzleite
                        This "infinite loading" bug happened several times one of them yesterday while loading the last match on theater mode, it stays on ilimited loading when the load bar is in full, also happened on MP (MTDM) games while loading, the bar goes full but gets stucked right there, after some seconds it turns PS3 off (after two bips).
                        Be it in the game or theater, the same ilimited loading ocurrs, RAM thing maybe ? it´s up to you to investigate just a tip, good luck.

                        P.S to reply here is hard, it takes us to the login page and the text just vanishes ...
                        • 9. Re: Official "Infinite Loading" Problem Thread
                          asystole
                          120GB Slim
                          Everything is hardwired - (I am currently playing hardwired into my modem direct)
                          NAT = Open
                          (note - some of these things are mentioned by others earlier)
                          The freeze which causes my reboot is during the load  from lobby and sits at "Awaiting other players" or a message close to that. Sometimes, if I want to wait, the screen will go black, and have the white colored "CALL OF DUTY - Black Ops" on the bottom right with a loading icon. It will then bring you back to a lobby alone.  However, this does not happen every time.

                          I also can hear people playing and talking but I do not know if they can hear me all the time.  (NOTE: sometimes they can hear you, as in the case of a party, party members in my experience can hear you), we do seem to get booted together, but not everyone has to reboot. Some just go back to the party lobby. Even then, it could be a "Phantom Lobby", where you think you are with the group but are really not.


                          I seem to have this problem more with a party, in any game mode except private matches. My first thought was the host was disconnecting during this process, causing everyone to have the problem, but we still cannot get everyone into a game most of the time.

                          My party is experiencing similar issues, but not everyone has the same results. Some get the checkerboard lobby before the game even loads. This has happened to me sometimes, but outcomes vary every time. It has been extreemly difficult to put a direct finger on the problem.

                          ID: Flatlines_Ghost (evenings 7-11pm EST)
                          1 2 3 Previous Next