3 Replies Latest reply on Sep 7, 2013 2:18 PM by Lord_Desies RSS

    Origins EE/Upgrade staff glitch

      Okay, so i attempted to start the ee last night in splitscreen with another, never upgraded staffs before etc, we did it on easy, and first we made the wind staff, and upgraded it to the point it needed souls in agartha, then we made ice, upgraded it placed it in agartha as well, then we collected these once samantha said we killed enough. SO then we make the other 2, with the lightning, took us a bit to work out the pattern and I was shotting at it radomly and it said it was done, thought this was odd but sweet it said it worked, ran round etc got all switches right, then placed in agartha, we did fire, upgraded it etc then placed in agartha, then we started killing there souls etc, fire worked first then lightning, even though it said to take the staff when we took the last 2 samantha didnt say the next step and the last 2 staffs werent red on the screen that shows if they are upgraded (when u press back on the controller). Nothing, what did we do wrong, it all was going fine until we picked them up when they said hold x etc, is it because it maybe glitched when i did the lightning piano thing? help, thanks