9 Replies Latest reply on Apr 20, 2014 2:54 AM by ssjzero RSS

    Active Network Connection - Virgin Media

      Hey all,


      I have spent the last 12 hours back and forth with Virgin trying to fix this.


      Upgraded to the new Superhub 2 with 100Mbps Fibre Optic.


      Internet works great, all devices work fine and so does my Xbox One - until I play Ghosts online.


      I have set a static IP and forwarded the correct ports as per this post here:

      Xbox Live Networking Ports for Xbox One


      However when playing a match I get thrown back to the menu with a message saying that an Active Network Connection is required to play xbox live - I dont get disconnected from xbox live at any point what so ever and didnt have the problem previously so there must simply be a setting thats wrong on the router but I dont know what it is.


      I have Open Nat, IPSec Pass-Through enabled and even Multicast Pass-through enabled, have even tried enabling DMZ on the Xbox IP.


      Any help would be greatly appreciated - would be nice to finish at least one match without it happening.

        • Re: Active Network Connection - Virgin Media

          One thing that MIGHT help is to reset your Mac Address. Its a longshot. This solved a lot of issues for me. Its somewhere on the bottom left of the screen on the net settings area.

          • Re: Active Network Connection - Virgin Media

            Do you have another multiplayer game that you could play to test the connection? What happens when you go into detailed network statistics from your network settings?

              • Re: Active Network Connection - Virgin Media

                I have been playing Titanfall and it works perfectly, no issues what so ever - it seems to simply be Call of Duty Ghosts on the XB1. I have also been playing Ghosts on the 360 and its fine too. It's just ridiculous and no one seems to have an answer.


                I have even tweeted Activision :[IMG]http://i1060.photobucket.com/albums/t453/Ben_Pedley/twitter_zps5013d76e.jpg[/IMG ]

                Who I don't think actually read my post properly.


                If someone could please take a look and let me know what they think here are my current router settings.


                Ports Forwarded: [IMG]http://i1060.photobucket.com/albums/t453/Ben_Pedley/portsforwarded_zpsc8f9af04.j pg[/IMG]

                IP Reserved:[IMG]http://i1060.photobucket.com/albums/t453/Ben_Pedley/xboxip_zpsfc875f71.jpg[/IMG]

                DMZ: [IMG]http://i1060.photobucket.com/albums/t453/Ben_Pedley/dmz_zpsc74bf109.jpg[/IMG]


                And I have tried it both with and without the Firewall on..


                When you run a test on the XB1 it says the network and multiplayer is perfectly fine. All internet devices are working and everything else xbox live works on the XB1.


                I can load Call of Duty Ghosts on my Xbox One, I can even search and get into a game but guaranteed every single time I get about half way through any game, any matchtype and then I get kicked back to the lobby and my screen looks like this: [IMG]http://i1060.photobucket.com/albums/t453/Ben_Pedley/2014-04-17073942_zps6a977405 .jpg[/IMG]


                No I do not want to connect through a Wired connection, Yes it previously worked fine on the Original Superhub from Virgin Media, I upgraded to the 100MB connection with the Superhub 2 to not only gain better speeds but to have a larger range from the equipment so I don't wish to revert back to an older system.


                It must be something silly that is causing this, could even be one setting but I'm sure I can't be the only person who is using 100MB Virgin Media Wirelessley with an Xbox One and Call of Duty Ghosts - So please if there is someone out there with the same set up could you please help.

                  • Re: Active Network Connection - Virgin Media

                    From what you describe, your connection is working properly until something interrupts it during ghosts. Without knowing the ins and outs of the ghosts networking code, it's hard to determine what that could be. The fact that it does not affect the 360 version is also a little strange. Have you tried a complete reinstall of ghosts? Deleting the entire game/dlc/savedata, cycle power to the xbox for 5 minutes to ensure cleared cache and then rebooting and reinstalling.

                    If that does not work, try removing and recovering your profile from your xbox one.


                    If that still does not work

                    Try these one at a time.

                    • Disable SIP ALG in router. Sometimes this causes problems with NAT. Even listed as Open, it could have problems.
                    • Turn on QOS and use mac address settings to select your xbox one. It will prioritize internet traffic for your xbox one.

                    And also make sure UPNP is turned on as well.


                    Be sure to restart your router after each setting change.

                      • Re: Active Network Connection - Virgin Media

                        Thanks for the advise so far but I cant change some of those settings on a Superhub 2.


                        However I have made some progress.


                        I uninstalled Everything to do with Ghosts.


                        I then re-downloaded the game (I have the digital gold edition) and re-installed, as I type this I have just finished my 6th consecutive match without any interruption what so ever (fingers crossed this will continue)


                        The extras I had installed where the season pass, festive pack, xbox pack, wolf skin, onslaught, devastation and free fall.


                        What is interesting is that the 6th match I had was on freefall even though it wasnt installed so this must not need to be downloaded anymore as it appears to be a part of the package.


                        I will attempt to play after installing one thing at a time - maybe its some of the dlc that is causing the issue. As for the router setup I have simply done thenport forwarding recommended on the official xbox forums, I didnt bother with dmz, firewall is on low.


                        I will post an update when I figure out which element is causing the issues but right now its looking like the game content, not the router....

                  • Re: Active Network Connection - Virgin Media



                    First and foremost, I am not Customer Support. I am unable to provide you direct support or guarantee a solution, but I am curious about this and wish to find a few more details out.


                    You've stated that you are able to play 360 too. How does that setup work?


                    Personally, I've issued my Xbox One and my Xbox 360 the same internal IP address. I simply turn one off when I'm ready to play the other and then proceed after a few minutes. At any point, where you connecting to Xbox Live with both consoles on?


                    Also: As far as I know, you need only choose to place your console in the DMZ or Port Forward it. Doing both is a bit unnecessary as once it's in the DMZ, it should, theoretically, no longer need the port forwarding table.


                    Regardless, I'm glad that you were able to get some matches going re-installing everything.

                      • Re: Active Network Connection - Virgin Media



                        I am no longer using Dmz, I have only set up a static IP for my Xbox One, my Xbox 360 is in another room and has always just been set to automatic.


                        Yes I have had both consoles on at the same time and signed into xbox live using the same account, however I have not already attempted to play on xbox live multiplayer on both at the same time,  1) I would assume it wouldnt work 2) I only have one pair of hands..lol


                        Port forwards seem to work best, when ever I tried using Dmz I found that when I logged back into the router the Superhub 2 had reset the Dmz section.


                        I have to go to work now but when I return this evening I will begin downloading dlc one pack at a time to see if it is one of these that caused my issues.

                          • Re: Active Network Connection - Virgin Media

                            Don't know if this will help but my info was to also forward port 3076 (both TCP and UDP). Also, not trying to be a smart-a$$ but double check and make sure that the IP you assigned within your hub is the same one that shows up in the settings section on the xbox one.


                            Good luck.



                        • Re: Active Network Connection - Virgin Media

                          Ok. So it looks like when I re-installed the game it was simply a coincidence.


                          So I took Starbuckfracks advise along with a post I found on Reddit which was as follows:

                          "i am also with virgin media & have superhub 2.. .i searched for days looking for a soloution... what worked for me was... Settings > network > Advanced settings > Alternate mac address > Clear... it will restart your xbox..

                          make sure that settings on router are correct too..

                          open these ports:

                          Port 88 (UDP) Port 3074 (UDP and TCP) Port 53 (UDP and TCP) Port 80 (TCP) Port 500 (UDP) UDP Port 3544 (UDP) UDP Port 4500 (UDP) 

                          have UPnP turned on. Also make sure that under "advanced settings > wireless" the wireless mode is set to "Up to 54Mbps (best for wireless compatibility)". This fixed all my problems of disconnects and party chat problems."


                          After following these details I have not been kicked out of a gane so far.


                          Then only other issue I have with Ghosts now is that last night I levelled one of my characters to 54 and this morning when I played on my Xbox One my character was level 47. Never mind.


                          If it turns out that not being kicked is merely another co-incidence I will reply to this post,  otherwise it seems fixed.